Building error


#21

Note PulseCLR project will be created but will NOT be built unless you enable it via a CMake flag, so it should not cause any issues. (if C# developers want it built as part of the solution, they just need to enable that flag)

ReadMe was updated


#22

For the Qt building, the build setting was Debug. I changed it to Release, but the error ‘libprotobuf.lib cannot be found’ still exists.

The following picture is the folder where the file libprotobuf.lib is located. I didn’t see the release subfolder mentioned in the error message.


#23

I created the Release folder myself and copied that file to this folder, then the problem was solved temporarily. The bad news is that another problem related to java appeared (as shown below):

In addition, I found this project is not compatible with the java higher than 1.8.0_121. Maybe you can check it later.


#24

I have run the build through qtCreator and received the same error you did
I know what the problem is and am working on a fix

This Java error is post-build (which is good!) and trying to generate data via a Java executable jar, and that jar is not finding its dependent jars for some reason…

You should have a run.cmake file in your install/bin directory
It should be setting the path to the jars in this section

set(JAVA_CLASSPATH Pulse.jar
    C:/Programming/physiology/engine/jar/javassist-3.16.1-GA.jar

In your file, are your paths to these jar files correct?


#25

I think the above java JNI error is caused by the space in the directory. After moving the source file to another directory that doesn’t contain spaces, the problem was solved. Now it’s generating data and states, and has lasted for a while. But the folder that accommodates libprotobuf.lib still cannot be generated automatically. I have to create it myself.


#26

Great!

Yes, I am fixing the folder issue

I need to add quotes to the paths in that run.cmake file, that should fix the issue of having spaces in the name


#27

The data and states have been generated successfully. And I have executed ‘run updateBaselines’ in the cmd. But the release folder under install/bin is empty, which means I cannot execute the PulseScenarioDriver. Any more steps needed?

By the way, do you have an UI to play with for this project?


#28

If it generated state data, the driver is there…

(look for files in install/bin/states)

This may help

https://gitlab.kitware.com/physiology/engine/wikis/Test%20Suite

Gui is here

https://gitlab.kitware.com/physiology/explorer


#29

There is an error when I built the explorer:

Every time when I rebuild the source file, it takes too much time to finish, about 16 minutes.


#30

You can download a prebuild windows version here:

https://gitlab.kitware.com/physiology/explorer/wikis/home

I will be adding a newer version with some more capability very soon

I’ll see if I can’t get a new windows copy up ASAP

I will probably need to build it and fix bugs with creator as well


#31

Great, thanks.


#32

I pushed up fixes to Pulse Master to fix the build folder issue.
It builds with no issues in Creator, I think it will also build in your ninja/MSVC environment too… but I have not integrated ninja into MSVC yet to really test it
(How did you do that?)

I am currently building a fresh pull of the Explorer that uses this new Pulse through Creator and will fix any of those issues I find.


#33

I uploaded the latest build of the Explorer here :
https://data.kitware.com/api/v1/file/5b46d19f8d777f2e6225a597/download

Let me know how it works or if you have questions.

I am still working out some Explorer kinks.
I did notice that when Qt Creator builds Pulse, the DLLs are twice the size and the engine runs very slow… I am not sure what is going on there…