No PyPulse.cp39-win_amd64.pyd in install/bin

When I do that I get the same result from earlier where there is no PyPulse in the sln file.

Is there a pybind11 folder under there?

It was in the cmake output

I do not see a pybind11 folder.

I notice that I have a builds folder that I created which has an innerbuild folder that is not populated. And I have a build folder which created itself during a build in MSVC which has an innerbuild folder with a sln file which is the one we were previously discussing. The builds folder that I created was the output folder for CMAKE and it has the external folder with pybind11 but nothing in the innerbuild folder.

You have to build the outer Pulse.sln to populate the external and Innerbuild directories. I’d suggest deleting all your build folders and starting from scratch.

I deleted everything and began to follow these steps:

When I get to the make -j4 step I get this error:
make: *** No targets specified and no makefile found. Stop.

If you are on windows, using msvc use these instructions

I used those instructions but there is no sln file in builds/pulse-engine. So I cannot complete the build.

I was able to redo the CMAKE and now have an sln file in builds/pulse-engine but I do not know how to build it. There is no button labeled “build”. This is what I am working with:

If I press CTRL+SHIFT+B I get this error:
MSBuild version 17.7.2+d6990bcfa for .NET Framework
MSBUILD : error MSB1011: Specify which project or solution file to use because this folder contains more than one project or solution file.

Visual Code does not come with a C++ compiler. I’m not sure how you have it set up.

I suggest you get the free visual studio community edition and enable the C++ support during the install and use that to build the Pulse.sln

If you have cygwin setup, you could change CMake to generate make files rather than visual studio files and see if that helps.

I got it to work by typing “msbuild Pulse.sln” in the console.