Configure Error

I’m trying to configure/run Pulse using the instructions posted here: https://gitlab.kitware.com/physiology/engine/-/wikis/Using%20MSVC but I keep getting a strange error:

the source folder contains all the files from the latest Pulse release. I’ve tried using older versions of both cmake and Visual Studios but I get the same result. Any tips?

Do you have a CMake log?
Did you just download and install Visual Studio?
One mistake that I sometimes see, is that when you install Visual Studio, by default, C++ support is not installed. You have to manually enable it in the installer to get the C/C++ compiler installed (By default C# is expected to be used)

Once you hit Configure on the CMake GUI, you should get log messages about the compiler you have chosen. This is what I get:

The C compiler identification is MSVC 19.24.28315.0
The CXX compiler identification is MSVC 19.24.28315.0
Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.24.28314/bin/Hostx64/x64/cl.exe
Check for working C compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.24.28314/bin/Hostx64/x64/cl.exe – works
Detecting C compiler ABI info
Detecting C compiler ABI info - done
Detecting C compile features
Detecting C compile features - done
Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.24.28314/bin/Hostx64/x64/cl.exe
Check for working CXX compiler: C:/Program Files (x86)/Microsoft Visual Studio/2019/Community/VC/Tools/MSVC/14.24.28314/bin/Hostx64/x64/cl.exe – works
Detecting CXX compiler ABI info
Detecting CXX compiler ABI info - done
Detecting CXX compile features
Detecting CXX compile features - done
Installing to N:/Temp/engine-REL_2_3_0_build/install
Setting build type to ‘Release’ as none was specified.
External project - Eigen
Eigen is here : N:/Temp/engine-REL_2_3_0_build/eigen/src/eigen
External project - protobuf
Patching protobuf OFF
protobuf is here : N:/Temp/engine-REL_2_3_0_build/protobuf/src/protobuf
External project - dirent
dirent is here : N:/Temp/engine-REL_2_3_0_build/dirent/src/dirent
I am NOT going to pull the latest Pulse Baselines!
Configuring done

Okay, I manually enabled C/C++ (or at least I think I did). Now I get this message in the log window:

Selecting Windows SDK version to target Windows 10.0.18362.
The C compiler identification is unknown
The CXX compiler identification is unknown
CMake Error at CMakeLists.txt:6 (project):
No CMAKE_C_COMPILER could be found.
CMake Error at CMakeLists.txt:6 (project):
No CMAKE_CXX_COMPILER could be found.
Configuring incomplete, errors occurred!
See also “C:/Users/tyree.cowell/Documents/ISAAC/Pulse-builds/CMakeFiles/CMakeOutput.log”.
See also “C:/Users/tyree.cowell/Documents/ISAAC/Pulse-builds/CMakeFiles/CMakeError.log”.

Hmm. It still seems that the compiler is not configured right.

Here is my C++ settings

You might want to try fully closing CMake and opening it again, and maybe also rebooting your machine when you are sure you have C++ support in Visual Studio

It works now! Not entirely sure what I did but thank you so much!

Great!
You also might have deleted your CMakeCache.txt located in the build directory, so CMake will start fresh and look for the compile a new.

Let us know if you have any other questions or cool applications with Pulse!

Thanks!

Privacy Notice