Engine does not run in Android Unity build (IL2CPP)

That android-arm using level 26 API ran on my occulus
I just created a default VR project in Unity 2022, added the Pulse Asset (from our repo, not the store), and copied the vitals monitor into the default vr scene

The line renderer we have does not seem to play well with being in a 3D world
I am messing with it, but no Unity expert, so maybe its something simple, but maybe not…

Here is the asset file

Still no luck for me on the Vive Focus 3 even using the .unitypackage file.
No changes were required to the build/player settings right?

Also, the line renderers seem to work great for me if I stream the game from a PC so there are no issues with that on my end.

I don’t thinks so
But I followed this tutorial in setting up my VR scene

I am still waiting on getting a Focus 3 from someone…

i think the line renderer issue can be fixed by setting a UI material in the inspector tab. however even with your updated libPulseC.so and libc++ files dropped into ArmV8 did not fix the lack of anything happening with the monitor when running on my quest 1 or 2 (just got the q2 this weekend).

im building to ARM64, is this why? i’m also crossing my fingers that it is not due to me using unity 2019.4.4 opposed to you using 2022

edit: to my knowledge meta requires apps uploaded to applab to be arm64, would love to be incorrect on that though

I am not sure how well the Occulus is supported in 2019.4
I can see if I can get a base VR in that version

2019 works fine with oculus, i have multiple projects that use it. i tried a fresh project with your asset file and built to quest but the monitor still was not populating data or the line renderers after building to APK.

could you upload the entire project you got running on your quest device? all it has was the PE assets

Here is the contents of my project, all inside a 2022 VR folder


1 Like

awesome, downloading and opening now:)

1 Like

awesome, downloading and opening now:)

thank you. its worked