Need help on superbuild

Dear CMB team,

I am having some weird issues with cmb-superbuild.
I am executing the following cmake command.
Executing command: "C:\Program Files\CMake\bin\cmake.EXE" --no-warn-unused-cli -DSUPERBUILD_PACKAGE_MODE:STRING=aeva -DENABLE_opencascadesession:STRING=ON -DCMAKE_EXPORT_COMPILE_COMMANDS:BOOL=TRUE -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo -Sc:/cmb-superbuild -BC:/cmb-build/RelWithDebInfo -G Ninja
This works well on my machine. But when my colleague uses the same command to build, the following error popped out.

[build] CMake Error at cmake/aevaDependencies.cmake:34 (find_package):
[build]   Found package configuration file:
[build]     C:/cmb-build/RelWithDebInfo/install/lib/cmake/smtk-22.07.100/smtkConfig.cmake
[build]   but it set smtk_FOUND to FALSE so package "smtk" is considered to be NOT
[build]   FOUND.  Reason given by package:
[build]   The following imported targets are referenced, but are missing:
[build]   DelaunayShape DelaunayMesh DelaunayMisc DelaunayValidation
[build]   DelaunayDiscretization vtkSMTKSourceExt vtkSMTKModelExt
[build] Call Stack (most recent call first):
[build]   CMakeLists.txt:25 (include)
[build] -- Configuring incomplete, errors occurred!
[build] See also "C:/cmb-build/RelWithDebInfo/superbuild/aevasession/build/CMakeFiles/CMakeOutput.log".
[build] See also "C:/cmb-build/RelWithDebInfo/superbuild/aevasession/build/CMakeFiles/CMakeError.log".
[build] CMake Error at C:/cmb-build/RelWithDebInfo/superbuild/sb-aevasession-configure.cmake:47 (message):
[build]   Failed with exit code 1

We tried to clean rebuild several times, it is always the same error. And this didn’t happen on my machine. The build process on my machine was smooth and successful.
Any help is appreciated!


Could you provide the install/lib/cmake/smtk-22.07.100/ directory from the broken build?

Are there any other oddities in the build log for smtk itself?

I attached a screen shot for the directory.

There were no other oddities.

I can confirm that target paraview and smtk were built successfully.

[build] -- Installing: C:/cmb-build/RelWithDebInfo/install/bin/smtk-22.07.100/smtkMeshSessionPlugin/smtkMeshSessionPlugin.dll
[build] -- Installing: C:/cmb-build/RelWithDebInfo/install/bin/smtk-22.07.100/smtkVTKSessionPlugin/smtkVTKSessionPlugin.dll
[build] -- Installing: C:/cmb-build/RelWithDebInfo/install/bin/smtk-22.07.100/smtkOscillatorSessionPlugin/smtkOscillatorSessionPlugin.dll
[build] -- Installing: C:/cmb-build/RelWithDebInfo/install/bin/TemplateEditor.exe
[build] [1/1   0% :: 0.279] Install the project...
[build] [392/409  95% :: 6434.264] Completed 'smtk'

Hi Yang - I think the problem you are having is actually related to CMake and not your environment. I think you are using version 3.24. Can you please download 3.23.1 and try doing a clean SuperBuild?

Hi Bob, it works!!! Thanks for the solution.

CMake maintainer here. Using 3.23 is not the solution, it’s just a diagnostic step. Some CMake change between 3.23 and 3.24 caused the superbuild to break - I’m doing a git-bisect right now to pinpoint the exact change.

1 Like

Actually Kyle for Yang it is a solution so that he can move forward since his work does not require 3.24. Yes it is a work around in the short term and Kitware still needs to figure out what regressed since other folks who need to use 3.24 will run into this.