I’m taking a survey of sorts. We are going to incorporate some external code (MIT license) into SMTK that subclasses QTableView to support multiple-row headers with column spanning. (I’ll paste a mockup below.) There are 4 classes in all (8 files) that I plan to add to smtk/extension/qt, but the original file names are a bit odd. Here are the original names along with what I have currently renamed them to. My “SMTK” names might be too generic and I am open to alternative suggestions.
Original Name
Description
Proposed SMTK Name
GridTableView
Subclass of QTableView
qtTableView
GridTableHeaderView
Subclass of QHeaderView
qtHeaderView
TableModel
Used by header view subclass
qtHeaderModel
TableModelItem
Used by header view subclass
qtHeaderModelItem
And here’s a mockup for a potential “attribute table view”:
First of all - this looks great! In terms of class names, we might want to be a bit more descriptive:
qtHeaderModel → gtGridHeaderModel
qtHeaderModelItem → qtGridHeaderModelItem (or if it was a class defined within qtGridHeaderModel then it could just be ModelItem)
qtHeaderView → qtGridHeaderView
qtTableView → qtAdvanceTableView
The proposed class names aren’t specific to attribute resources, but the classes are. Is it time to split+move smtk/extension/qt into smtk/qt/attribute and smtk/qt/resource?
Actually they are not related to attributes at all. There needs to be a new qtView class that is derived from qtBaseAttributeView - this will be attribute related.