Trouble Starting Pulse Explorer on Intel macOS


I’m an anaesthetist in training and deliver simulation in the UK. I am reasonably command-line literate but have no formal coding background. I came across the Pulse Engine recently as we would like to sandbox some games to supplement our SIM curriculum, and was hoping to play around with Pulse Explorer, but to my shame cannot even get it to run on my mac.

I get the following log every time, do you have any advice? Thanks in advance

Process: PulseExplorer [32720]
Path: /Applications/
Identifier: ???
Version: ??? (3.1.0)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: PulseExplorer [32720]
User ID: 501

Date/Time: 2024-03-02 03:24:08.674 +0000
OS Version: macOS 11.7.10 (20G1427)
Report Version: 12
Anonymous UUID: B13820C6-193E-4353-10F5-7AB2D55F279C

Sleep/Wake UUID: 927928D5-139A-4D33-9648-B5AB4B562731

Time Awake Since Boot: 310000 seconds
Time Since Wake: 10000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000005f05000

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [32720]

VM Regions Near 0x5f05000:

__TEXT 105f05000-1066ed000 [ 8096K] r-x/r-x SM=COW /Applications/

Thread 0 Crashed:: Dispatch queue:
0 ??? 0x0000000005f05000 0 + 99635200
1 0x0000000105f7a0eb QVentilatorWidget::Private::setupInitialValues() + 123
2 0x0000000105f77725 QVentilatorWidget::Private::Private(QVentilatorWidget*) + 229
3 0x0000000105f73b67 QVentilatorWidget::QVentilatorWidget(QWidget*, QFlagsQt::WindowType) + 87
4 0x0000000105f135ad Ui_MainExplorerWindow::setupUi(QMainWindow*) + 5069
5 0x0000000105f114a1 MainExplorerWindow::MainExplorerWindow() + 369
6 0x0000000105f11278 main + 664
7 libdyld.dylib 0x00007fff208a0f3d start + 1

Thread 1:
0 libsystem_pthread.dylib 0x00007fff20881420 start_wqthread + 0

Thread 2:
0 libsystem_pthread.dylib 0x00007fff20881420 start_wqthread + 0

Thread 3:
0 libsystem_pthread.dylib 0x00007fff20881420 start_wqthread + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000600000ccd860 rbx: 0x00007fdcd6882c00 rcx: 0x00000001066f1dc8 rdx: 0x00000000f749dffb
rdi: 0x0000600000ccd860 rsi: 0x0000000106770f70 rbp: 0x00007ffee9cfa6f0 rsp: 0x00007ffee9cfa6b8
r8: 0x00009e22588ad860 r9: 0x0000000000000020 r10: 0x00007fdcd5e00000 r11: 0x0000000000000000
r12: 0x00006000019dd140 r13: 0x00007fdcd6882de8 r14: 0x0000000106770f70 r15: 0x00007fdcd6882f90
rip: 0x0000000005f05000 rfl: 0x0000000000010202 cr2: 0x0000000005f05000

Logical CPU: 0
Error Code: 0x00000014 (no mapping for user instruction read)
Trap Number: 14

Thread 0 instruction stream not available.

Thread 0 last branch register state not available.

What kind of mac do you have?

Thanks for your swift reply! I have a 2015 MacBook pro running Big Sur.

Ok, I have something comperable, let me test it on there and see if I see the same

I was able to pull the dmg from our wiki and it was able to run by opening the DMG and dragging the Pulse icon over to my Applications folder. Then I just open it from my Applications. (I am not a Mac person, so just being explicit)

This is what I am running on

We targeted the dmg build for MacOS 11, which is Big Sur, but it’s possible that we are not compatible with that OS for some reason even though that is the latest version os Big Sur… Do you maybe have another Mac to try this on with at least Monterey?

I will need to ask around my Mac people to see if they have an idea of this type of error.

Hey @LittleSimz

I got a Big Sur machine and I am seeing the same error you are with it.

We tried targeting MacOS 11 when we built the explorer, but it seems that it did not work
It seems that Apple has also stopped supporting this version, maybe this might have something to do with our build not working on it.

I built the explorer on my BigSur machine, Hopefully this works for you
You can get the dmg here

You will need to remove the quarantine flag by running xattr -d /path/to/your/ .

Thank you for all the input!!! I can now run your build on Big Sur! FIY I managed to test the official dmg on a friend’s Monterey, and it runs fine there, so just as you expected. Thanks a million for all your help!


Let us know if you have any questions