SMTK and Qt 5.12.0

I have been able to build CMB+SMTK linked to Qt 5.12 on macos 10.14 (mojave) using the Qt binaries from homebrew (i.e., a bottled build). I have not done extensive testing.

Dark mode seems to work.

However, I did have to mark modelbuilder to run in “low resolution” mode, using Finder’s information dialog:

in order to avoid a rendering problem:

Note that the quarter-sized render area problem is independent of dark mode. However, this rendering issue only occurs when running the application in a debugger started in a terminal. Running the application by double-clicking never seems to suffer from the problem.

@cory.quammen This is the same rendering issue I have been having with ParaView (and is exhibited by the ParaView build in the modelbuilder superbuild). So at least I have a workaround (run in low resolution mode or start the app using Finder).

1 Like

This looks great!

@dcthomp I have just built using Qt 5.12.0 from their installer. In my build, both ParaView and ModelBuilder have no GUI elements (despite their being enabled in the View menu). Any suggestions?

Have you verified that Qt applications bundled with your Qt build run properly? For example, can you run Qt Designer.app?

can you run Qt Designer.app?

Yup, it runs just fine. @Bob_Obara Have you given this a shot yet? Maybe I am just lucky.

Hmm, ModelBuilder renders just fine when I build it outside of the superbuild. I’ll bet there’s something funny with my superbuild’s configuration. Sorry for the noise!

Sorry Guys,

I’ve been running around getting my presentation ready for tomorrow’s trip - will try to get to it when I get back.

Bob
Robert M. O’Bara, MEng.
Assistant Director of Scientific Computing

Kitware Inc.
28 Corporate Drive
Suite 101
Clifton Park, NY 12065

Phone: (518) 881- 4931

Here is what I got from running modelbuilder in superbuild/cmb/build with Qt5.12 on the new MBP2018+mojave:


The good news is that I have the resource panel now which I don’t have when building against qt5.9. Still the render view is funky here.

Low resolution mode is not helping here.

@dcthomp Do you happen to have the environment variable DASHBOARD_TEST_FROM_CTEST set in your terminal? That tells the widget to run in low-resolution mode.

FYI I run ParaView from Terminal.app all the time without seeing the quarter-size rendering you are seeing.

1 Like

Yup, that was it! It also does other Qt things that I enjoyed (like not popping prompts or adding menu animations), but I would rather have a full-size render window.

1 Like
Privacy Notice